image category is not

  • @cmpengineers said in image category is not:

    Base table or view not found

    please go through with link
    hope this will work for you.

  • @Vaishali-Agarwal

    its not working same error exactly


  • Hello

    every time i do composr intall it give me the same error

    Screen Shot 2020-10-17 at 10.58.42 AM.png

    why is he looking for base table !!! and still I did not do migrate or seed !!!


  • @cmpengineers
    if you have not run migrate command then please run
    php artisan migrate , it will show you the exact error.

  • @Vaishali-Agarwal

    same error my dear what ever command for artisan it will give me the same error


  • i found the solution

    which is weird , i copy one table the channels and insert inside the database it work , then i did
    php artisan migrate:fresh --seed

    it work but i have problem with multi-vendor
    so please check the image its not displaying

    Screen Shot 2020-10-17 at 11.40.53 AM.png


  • @cmpengineers
    once try to follow the below step:

    1. go to the .env and check the database name should be valid
    2. run the below command,
      php artisan config:cache
      php artisan migrate:refresh --seed

  • @cmpengineers
    link your storage folder

    php artisan storage:link

    you may also follow all the possible solution mention here

  • @Vaishali-Agarwal

    its already linked

    Generated optimized autoload files containing 6627 classes
    (base) drov112:pa s:l
    The "public/storage" directory already exists.
    (base) drov112:

  • @Vaishali-Agarwal

    Dear Vaishali

    i have already created more than 10+ project from laravel

    i did exactly and still its not showing I'm using laravel valet


  • @cmpengineers

    • Inspect to the image and check the image path

    • could you please check whether products or categories images are showing at admin end or front end both?

    You can see this issue does not exist at my end

  • @Vaishali-Agarwal said in image category is not:

    everything is showing except for the multi-vendor
    in production is working fine but in local its not working


  • @Vaishali-Agarwal

    what local env you are using laravel valet ? homestead vapor ? xampp ?


  • @cmpengineers
    I am using Linux server.

  • @Vaishali-Agarwal

    Dear Vaishali

    everything its working now but in production I cant upload category image
    Screen Shot 2020-10-17 at 5.11.41 PM.png

    Illuminate\Database\QueryException thrown with message "SQLSTATE[42000]: Syntax error or access violation: 1305 FUNCTION drovapp.get_url_path_of_category does not exist (SQL: update `categories` set `_lft` = case when `_lft` >= 18 then `_lft`+2 else `_lft` end, `_rgt` = case when `_rgt` >= 18 then `_rgt`+2 else `_rgt` end where (`_lft` >= 18 or `_rgt` >= 18))"
    #62 Illuminate\Database\QueryException in /home/forge/
    #61 Doctrine\DBAL\Driver\PDOException in /home/forge/
    #60 PDOException in /home/forge/
    #59 PDOStatement:execute in /home/forge/
    #58 Doctrine\DBAL\Driver\PDOStatement:execute in /home/forge/
    #57 Illuminate\Database\Connection:Illuminate\Database\{closure} in /home/forge/
    #56 Illuminate\Database\Connection:runQueryCallback in /home/forge/
    #55 Illuminate\Database\Connection:run in /home/forge/
    #54 Illuminate\Database\Connection:affectingStatement in /home/forge/
    #53 Illuminate\Database\Connection:update in /home/forge/
    #52 Illuminate\Database\Query\Builder:update in /home/forge/
    #51 Kalnoy\Nestedset\QueryBuilder:makeGap in /home/forge/
    #50 Webkul\Category\Models\Category:insertNode in /home/forge/
    #49 Webkul\Category\Models\Category:insertAt in /home/forge/
    #48 Webkul\Category\Models\Category:actionAppendOrPrepend in /home/forge/
    #47 call_user_func_array in /home/forge/
    #46 Webkul\Category\Models\Category:callPendingAction in /home/forge/
    #45 Webkul\Category\Models\Category:Kalnoy\Nestedset\{closure} in /home/forge/
    #44 Illuminate\Events\Dispatcher:Illuminate\Events\{closure} in /home/forge/
    #43 Illuminate\Events\Dispatcher:dispatch in /home/forge/
    #42 Illuminate\Events\Dispatcher:until in /home/forge/
    #41 Illuminate\Database\Eloquent\Model:fireModelEvent in /home/forge/
    #40 Illuminate\Database\Eloquent\Model:save in /home/forge/
    #39 Webkul\Category\Models\Category:create in /home/forge/
    #38 Webkul\Category\Repositories\CategoryRepository:create in /home/forge/
    #37 Webkul\Category\Http\Controllers\CategoryController:store in /home/forge/
    #36 call_user_func_array in /home/forge/
    #35 Illuminate\Routing\Controller:callAction in /home/forge/
    #34 Illuminate\Routing\ControllerDispatcher:dispatch in /home/forge/
    #33 Illuminate\Routing\Route:runController in /home/forge/
    #32 Illuminate\Routing\Route:run in /home/forge/
    #31 Illuminate\Routing\Router:Illuminate\Routing\{closure} in /home/forge/
    #30 Illuminate\Pipeline\Pipeline:Illuminate\Pipeline\{closure} in /home/forge/
    #29 Webkul\User\Http\Middleware\Bouncer:handle in /home/forge/
    #28 Illuminate\Pipeline\Pipeline:Illuminate\Pipeline\{closure} in /home/forge/
    #27 Illuminate\Routing\Middleware\SubstituteBindings:handle in /home/forge/
    #26 Illuminate\Pipeline\Pipeline:Illuminate\Pipeline\{closure} in /home/forge/
    #25 Illuminate\Foundation\Http\Middleware\VerifyCsrfToken:handle in /home/forge/
    #24 Illuminate\Pipeline\Pipeline:Illuminate\Pipeline\{closure} in /home/forge/
    #23 Illuminate\Session\Middleware\AuthenticateSession:handle in /home/forge/
    #22 Illuminate\Pipeline\Pipeline:Illuminate\Pipeline\{closure} in /home/forge/
    #21 Illuminate\View\Middleware\ShareErrorsFromSession:handle in /home/forge/
    #20 Illuminate\Pipeline\Pipeline:Illuminate\Pipeline\{closure} in /home/forge/
    #19 Illuminate\Pipeline\Pipeline:then in /home/forge/
    #18 Illuminate\Routing\Router:runRouteWithinStack in /home/forge/
    #17 Illuminate\Routing\Router:runRoute in /home/forge/
    #16 Illuminate\Routing\Router:dispatchToRoute in /home/forge/
    #15 Illuminate\Routing\Router:dispatch in /home/forge/
    #14 Illuminate\Foundation\Http\Kernel:Illuminate\Foundation\Http\{closure} in /home/forge/
    #13 Illuminate\Pipeline\Pipeline:Illuminate\Pipeline\{closure} in /home/forge/
    #12 Barryvdh\Debugbar\Middleware\InjectDebugbar:handle in /home/forge/
    #11 Illuminate\Pipeline\Pipeline:Illuminate\Pipeline\{closure} in /home/forge/
    #10 Illuminate\Session\Middleware\StartSession:handle in /home/forge/
    #9 Illuminate\Pipeline\Pipeline:Illuminate\Pipeline\{closure} in /home/forge/
    #8 Illuminate\Cookie\Middleware\AddQueuedCookiesToResponse:handle in /home/forge/
    #7 Illuminate\Pipeline\Pipeline:Illuminate\Pipeline\{closure} in /home/forge/
    #6 Illuminate\Cookie\Middleware\EncryptCookies:handle in /home/forge/
    #5 Illuminate\Pipeline\Pipeline:Illuminate\Pipeline\{closure} in /home/forge/
    #4 Illuminate\Foundation\Http\Middleware\CheckForMaintenanceMode:handle in /home/forge/
    #3 Illuminate\Pipeline\Pipeline:Illuminate\Pipeline\{closure} in /home/forge/
    #2 Illuminate\Pipeline\Pipeline:then in /home/forge/
    #1 Illuminate\Foundation\Http\Kernel:sendRequestThroughRouter in /home/forge/
    #0 Illuminate\Foundation\Http\Kernel:handle in /home/forge/

    my SQL version is 5.7

    I did alter the database still not working
    ALTER DATABASE drovapp DEFAULT CHARACTER SET utf8 COLLATE utf8_unicode_ci;

    I can add product image no problem only the category


Log in to reply