Never mind I got it. For reference of other folks, here is how setting should be - Select all the currencies under 'Currencies'