Recent Topics

composar install problem phpoffice/phpspreadsheet



  • local install on mint 19 with composer gives these errors,
    ie. composer does not install phpoffice/phpspreadsheet

    ran
    composer require phpoffice/phpspreadsheet
    in terminal , also tried as su, to no avail.


    here follows the error output after composer install :

    Problem 1
    - phpoffice/phpspreadsheet 1.7.0 requires ext-gd * -> the requested PHP extension gd is missing from your system.
    - phpoffice/phpspreadsheet 1.6.0 requires ext-gd * -> the requested PHP extension gd is missing from your system.
    - maatwebsite/excel 3.1.x-dev requires phpoffice/phpspreadsheet ^1.6 -> satisfiable by phpoffice/phpspreadsheet[1.6.0, 1.7.0].
    - Installation request for maatwebsite/excel 3.1.x-dev -> satisfiable by maatwebsite/excel[3.1.x-dev].



  • This post is deleted!


  • gd extentions need to install



  • Is this issue related to bagisto installation?


Log in to reply