Recent Topics

Unable to display or run video in Admin Dashboard (Review Module)

  • Hi,

    I have made new package to override product review module, Now the product is taking video reviews too and the customer side is working fine and storing path in db too against products.

    On the admin side, I am unable to play video on review section, the video is not playing even I have given the correct storage path etc + any other video with open link is also not playing.

    Please explain why the admin dashboard is not allowing videos to play.

    The video path getting code:
    <div class="control-group">
    <label for="name" >Attachment</label>
    <video width="320" height="240" controls>
    <source src="" type="video/mp4">
    Your browser does not support the video tag.

  • Hi @Aymun-Dar
    Kindly check error why it is not playing using dev tool present inside browser and share screenshot.

  • Path

    Customer View.png

    Error Which is not code based I guess
    I am runny my project on virtual host rn,

    Customer View error.png

    This is the only run time error I am getting, and the path is this.

  • Hi @Aymun-Dar

    I have checked the code that is given above by integrating it in my admin panel and it is working fine kindly check your code there may be some other problem. I have also attached the video for your reference


  • Thanks Vishal, But the problem is still the same, I have done exactly what you are doing here. Any kind of video is not working under video tag.
    I have tried getting path through "asset", "Storage::url","url" and even hardcoded the whole path. But nothing is working.
    These are my folder structure and code files,


    Inspected Code path

    folder structure, where video is working fine

    Is there any kind of package that we need to download to stream videos in bagisto?


  • Hi @Aymun-Dar

    No, Bagisto did not required any extra package for this. First of all kindly check the video on the other tab and check weather it is playing or not use the same path that you use inside Bagisto.
    If it is not playing than there is permission issue.

  • @vishalK

    Thankyou for your help, I have solved the issue, it was storage link issue,
    Actually during package generation, I some how unlinked the public storage.
    So when I was trying to get the video It was appearing on my storage folder but not available on Public>Storage.

    I then deleted that folder and run the command "php artisan storage:link" which solved my issue.


Log in to reply