Recent Topics

No Acces to Front, Register and noAdmin login (account) [SOLVE]



  • On a fresh install with composer on : WSL/ubuntu20.4 / nginx

    Follow : https://github.com/bagisto/bagisto

    No error during install.

    I'm not able to have the front side : Home and customer page :

    Trying to get property 'default_locale' of non-object
    /var/www/local.websites/local.fripus/packages/Webkul/Shop/src/Http/Middleware/Locale.php#44
    

    At the /admin login : "Please check your credentials and try again." with [email protected] /admin123

    the admins table is empty on my database 😞

    mysqld --version : Ver 8.0.22-0ubuntu0.20.04.3
    npm7.3.0
    php 7.4.3
    Laravel 7.14.1

    Any idea ?



  • @Hardkiffeur
    you just need to run the below command from the root directory of the project

    php artisan db:seed
    
    composer dump-autoload
    
    php artisan vendor:publish & press 0 to continue
    


  • Hi @Hardkiffeur what method did you use to install Bagisto (web install or console) ?



  • Thankx a lot Vaishali & Ghermans for the time 😉
    First for Ghermans : with the composer routine like I said on my first post.

    php artisan db:seed : Error In Connection.php line 671

    Error-Bagisto-install.jpg
    And two others :

    In PDOConnection.php line 63:
      SQLSTATE[42S22]: Column not found: 1054 Unknown column 'default_name' in 'field list'
    In PDOConnection.php line 61:
      SQLSTATE[42S22]: Column not found: 1054 Unknown column 'default_name' in 'field list'
    

    Then trying to make a 'php artisan migrate:fresh' => Get the Super privilege needed for the Create trigger ! into the Connection.php line 671 same for :

    In PDOConnection.php line 43:
      SQLSTATE[HY000]: General error: 1419 You do not have the SUPER privilege and binary logging is enabled (you *might* want to use the less safe log_bin_trust_function_creators variable)
    In PDOConnection.php line 41:
      SQLSTATE[HY000]: General error: 1419 You do not have the SUPER privilege and binary logging is enabled (you *might* want to use the less safe log_bin_trust_function_creators variable)
    

    This is a DevStack issue for me no ? so gonna check my sql configuration and/or start with Docker and let U know 😉

    HK



  • Ok so I've made what sql said me :
    log with admin right on mysql and run :

    SET GLOBAL log_bin_trust_function_creators = 1;
    

    Then All three steps share by Vaishali could be run and I've the front / custommer / admin !

    Thanks for the time !

    HK


Log in to reply