Recent Topics

Front end Product Image not displaying in V1.3.2

  • Hi Team,

    I have recently tried to update the bagisto Version from 1.3.1 to 1.3.2. After updating the store fromt end images are not displaying the other logos and admin pannel Images are shown as usual. The images are present in storage folder.

    I have tried the belwo commands as well but no luck i been searching for solution for last 2 days no break through.

    Steps I followed to update bagisto:

    Commands I tried too solve the issue.
    I have unlink the storage and create a new link
    php artisan storage:link

    but not working !!!

    php artisan route:cache
    php artisan config:cache
    php artisan optimize

    the .env file has the APP_URL=

    after the change i configured the cache but no luck.

    Is there anything I am missing ?


    Can anyone help me to resolve it??

  • may be you need to update the 'APP_URL' in the .env file, by replacing http://localhost with your url

  • Hi.

    Please confirm if you're using any other modules, with Bagisto.
    Also, if you're using xampp and If no domain is mapped to the project folder, use http://localhost/project_folder/public in APP URL.

  • Hello, I've solved the problem.
    The issue was in the file '<project_root>/bootstrap/cache/config.php' at the imagecache array. Please, check the following code lines that must be:

    'imagecache' =>
      array (
        'route' =>'cache' ,
        'paths' =>
        array (
          0 => '/<project_root>/storage/app/public',
          1 => '/<project_root>/public/storage',
        'templates' =>
        array (
          'small' => 'Webkul\\Product\\CacheFilters\\Small',
          'medium' => 'Webkul\\Product\\CacheFilters\\Medium',
          'large' => 'Webkul\\Product\\CacheFilters\\Large',
        'lifetime' => 43200,

    In my case, I found out that:

    • 'route' was NULL
    • arrays apparently pointing to no sense folder

Log in to reply