Composer install problem
Ratan last edited by
Problem is faced when I going to install composer. what do I have to do? problem that I faced is given bellow:
Loading composer repositories with package information
Your requirements could not be resolved to an installable set of packages.
- maatwebsite/excel[3.1.28, ..., 3.1.30] require phpoffice/phpspreadsheet 1.16.* -> satisfiable by phpoffice/phpspreadsheet[1.16.0].
- maatwebsite/excel[3.1.31, ..., 3.1.x-dev] require phpoffice/phpspreadsheet ^1.18 -> satisfiable by phpoffice/phpspreadsheet[1.18.0, ..., 1.23.0].
- maatwebsite/excel 3.1.27 requires phpoffice/phpspreadsheet ^1.16 -> satisfiable by phpoffice/phpspreadsheet[1.16.0, ..., 1.23.0].
- maatwebsite/excel 3.1.26 requires phpoffice/phpspreadsheet ^1.15 -> satisfiable by phpoffice/phpspreadsheet[1.15.0, ..., 1.23.0].
- phpoffice/phpspreadsheet[1.15.0, ..., 1.23.0] require ext-gd * -> it is missing from your system. Install or enable PHP's gd extension.
- Root composer.json requires maatwebsite/excel ^3.1.26 -> satisfiable by maatwebsite/excel[3.1.26, ..., 3.1.x-dev].
To enable extensions, verify that they are enabled in your .ini files:
You can also run
php --iniin a terminal to see which files are used by PHP in CLI mode.
Alternatively, you can run Composer with
--ignore-platform-req=ext-gdto temporarily ignore these required extensions.
Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions.
sanjay-webkul last edited by
Are you trying setup bagisto on your system ?