Recent Topics

Repository does not exist



  • I have installed bagisto on my Ubuntu using CLI commands the installation was successful and I didn't got any issue while installation and I run command "php artisan serve" I get a successful run and get my localhost link with port which is http://127.0.0.1:8000/ and when I hit this URL in browser to see the out put I get the error "Class Webkul\Core\Repositories\SliderRepository does not exist" I dont understand what to do next please help!



  • are you using the master branch from GitHub or the release zipfile?
    I just did a clean install with the following commands (I suppose you did this too)

    git clone https://github.com/bagisto/bagisto.git
    cd bagisto
    composer install
    artisan serve
    

    Once the installation procedure was completed i get the store
    alt text



  • @ghermans Thanx for replying and no I used the commands which are given in Bagisto documentation from here https://devdocs.bagisto.com/index.html#installation I followed each step with CLI and GUI as well but the end result was same. Let me check it with your way. I hope it works.



  • @ghermans Thank you for your help it worked! didn't got any slider or products though but got the store.



  • i am getting same issue, although i tried to to install following two ways and different version 0.1.6 and 0.1.7 beta

    ReflectionException
    Class Webkul\Core\Repositories\SliderRepository does not exist
    Previous exceptions
    Declaration of Webkul\Core\Eloquent\Repository::count() should be compatible with Prettus\Repository\Eloquent\BaseRepository::count(array $where = Array, $columns = '*') (0)
    

    and

    // of resolutions and let reflection attempt to determine the result.
                if ($this->hasParameterOverride($dependency)) {
                    $results[] = $this->getParameterOverride($dependency);
     
                    continue;
                }
     
                // If the class is null, it means the dependency is a string or some other
                // primitive type which we can not resolve since it is not a class and
                // we will just bomb out with an error since we have no-where to go.
                $results[] = is_null($dependency->getClass())
                                ? $this->resolvePrimitive($dependency)
                                : $this->resolveClass($dependency);
            }
     
            return $results;
        }
     
        /**
         * Determine if the given dependency has a parameter override.
         *
         * @param  \ReflectionParameter  $dependency
         * @return bool
         */
        protected function hasParameterOverride($dependency)
        {
            return array_key_exists(
                $dependency->name, $this->getLastParameterOverride()
            );
        }
     
    Arguments
    "Class Webkul\Core\Repositories\SliderRepository does not exist"
    


  • i use master branch from git repo, and it's fixed the issue.



  • Does anyone solved this?



  • Hi @artleminh

    Please use below step for installation.

    Follow below step.

    git clone https://github.com/bagisto/bagisto.git
    

    then

    cd bagisto
    
    composer install
    

    then run migrate and seed. Rest of process will be same.

    Thanks


Log in to reply