Recent Topics

Install error with master branch, missing features in admin panel



  • Hello,

    I am facing some features missing under admin panel after installing using master copy, in "Setting", "Category" section.
    Also tried to npm install and npm run watch under "admin" and "ui", but getting following issue. Please give me advice how to correct it. Thanks a lot.

    ERROR in ./resources/assets/sass/app.scss
    Module build failed (from ./node_modules/css-loader/index.js):
    ModuleBuildError: Module build failed (from ./node_modules/sass-loader/dist/cjs.js):
    Error: Dart Sass version 1.23.0-module.beta.1 is incompatible with ^1.3.0.
        at getRenderFuncFromSassImpl (/opt/services/nginx/com.esxa/bagisto/node_modules/sass-loader/dist/index.js:159:13)
        at Object.loader (/opt/services/nginx/com.esxa/bagisto/node_modules/sass-loader/dist/index.js:79:18)
        at /opt/services/nginx/com.esxa/bagisto/node_modules/webpack/lib/NormalModule.js:313:20
        at /opt/services/nginx/com.esxa/bagisto/node_modules/loader-runner/lib/LoaderRunner.js:367:11
        at /opt/services/nginx/com.esxa/bagisto/node_modules/loader-runner/lib/LoaderRunner.js:233:18
        at runSyncOrAsync (/opt/services/nginx/com.esxa/bagisto/node_modules/loader-runner/lib/LoaderRunner.js:143:3)
        at iterateNormalLoaders (/opt/services/nginx/com.esxa/bagisto/node_modules/loader-runner/lib/LoaderRunner.js:232:2)
        at /opt/services/nginx/com.esxa/bagisto/node_modules/loader-runner/lib/LoaderRunner.js:205:4
        at /opt/services/nginx/com.esxa/bagisto/node_modules/enhanced-resolve/lib/CachedInputFileSystem.js:73:15
        at processTicksAndRejections (internal/process/task_queues.js:75:11)
     @ ./resources/assets/sass/app.scss
    
    ERROR in ./resources/assets/sass/app.scss (./node_modules/css-loader??ref--5-2!./node_modules/postcss-loader/src??postcss0!./node_modules/resolve-url-loader??ref--5-4!./node_modules/sass-loader/dist/cjs.js??ref--5-5!./resources/assets/sass/app.scss)
    Module build failed (from ./node_modules/sass-loader/dist/cjs.js):
    Error: Dart Sass version 1.23.0-module.beta.1 is incompatible with ^1.3.0.
        at getRenderFuncFromSassImpl (/opt/services/nginx/com.esxa/bagisto/node_modules/sass-loader/dist/index.js:159:13)
        at Object.loader (/opt/services/nginx/com.esxa/bagisto/node_modules/sass-loader/dist/index.js:79:18)
     @ ./resources/assets/sass/app.scss 2:14-265
    


  • @bzero
    Greetings of the day.

    Would you care to share your NPM and Node version that are installed on your system.



  • @bagisto-mogul please see below

    [email protected]:~# node -v
    v12.10.0
    [email protected]:~# npm -v
    6.10.3
    [email protected]:~#
    


  • any update on this error?

    Thank you.



  • @bzero
    I recommend you to use Node 8.11LTS till we figure out support form higher versions.



  • @bagisto-mogul
    i installed node 8.11 lts, and reinstall bagisto from mater branch, but the issue still happens same.

    i run npm run watch after npm instal in "ui", and it shows as below, seems still not completed

    > cross-env NODE_ENV=development node_modules/webpack/bin/webpack.js --progress --hide-modules --config=node_modules/laravel-mix/setup/webpack.config.js "--watch"
    
    10% building 1/1 modules 0 active
    webpack is watching the files…
    
    98% after emitting SizeLimitsPlugin
    
     DONE  Compiled successfully in 13709ms                                                                                   14:31:01
    
           Asset      Size   Chunks             Chunk Names
    /css/app.css   173 KiB  /js/app  [emitted]  /js/app
      /js/app.js  1.38 MiB  /js/app  [emitted]  /js/app
    
    

    By the way, i don't see folder "shop". Is it normal?



  • @bzero Strange as the output show vendor directory such as ui or shop. But most of concern is your instance using new compiled files or not?



  • @bagisto-mogul
    Do you mean about my system? i am using VPS, running debian 10.


Log in to reply