Recent Topics

Error in phase migration and seed



  • this line is not working

    I tested the 3rd answer in the link and it works, and gave different error

    
    , Illuminate\Database\QueryException : SQLSTATE[HY000] [1045] Access denied for user 'forge'@'localhost' (using password: NO) (SQL: select * from information_schema.tables where table_schema = forge and table_name = migrations),, at /home/bagisto/bagisto-0.1.5/vendor/laravel/framework/src/Illuminate/Database/Connection.php:664, 660| // If an exception occurs when attempting to run a query, we'll format the error, 661| // message to include the bindings with SQL, which will make this exception a, 662| // lot more helpful to the developer instead of just the database's errors., 663| catch (Exception $e) {, > 664| throw new QueryException(, 665| $query, $this->prepareBindings($bindings), $e, 666| );, 667| }, 668|,, Exception trace:,, 1 Doctrine\DBAL\Driver\PDOException::("SQLSTATE[HY000] [1045] Access denied for user 'forge'@'localhost' (using password: NO)"), /home/bagisto/bagisto-0.1.5/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php:31,, 2 PDOException::("SQLSTATE[HY000] [1045] Access denied for user 'forge'@'localhost' (using password: NO)"), /home/bagisto/bagisto-0.1.5/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php:27,, Please use the argument -v to see more details.
    
    

    The lines I used was

    sudo chgrp -R www-data storage bootstrap/cache
    sudo chmod -R ug+rwx storage bootstrap/cache
    

    BTW I'm using LEMP ISO on Vultr



  • This post is deleted!


  • This post is deleted!


  • Follow the link and setup the database credentials for your project in .env file

    https://github.com/bagisto/bagisto/edit/master/README.md



  • OK, I gave up using UI installer and use manual install instead.
    The installation is successful, but when I go to the URL,

    • I have to use http://URL/public/ to access, how can I change to http://URL instead?

    • The website loads, but I cannot click anything in the demo

    • I also cannot open admin login



  • To open the admin panel, the directory will be http://localhost/(folder name)/bagisto/public/admin/login

    The credentials will be : [email protected], admin123





  • Hello,

    You have missed your server configuration that's why any route is not working.
    If you are using apache2 serve then you can do following.

    Step-1
    Open our apache2.conf file ( etc->apache2)

    Step2
    There you can find some think like this-

    <Directory /home/users/www>
    Options Indexes FollowSymLinks
    AllowOverride none
    Require all granted
    </Directory>

    change it to
    <Directory /home/users/www>
    Options Indexes FollowSymLinks
    AllowOverride All
    Require all granted
    </Directory>

    Note - Directory structure will be different in your case & may be some value

    Step-3
    Run the below command -
    sudo a2enmod rewrite
    sudo /etc/init.d/apache2 restart
    or
    sudo service apache2 restart
    php artisan route:cache

    Thanks
    Rahul Shukla



  • I'm using nginx BTW



  • Please search for same.


Log in to reply