Recent Topics

Bagisto: search by category



  • Hello,
    The search that is at the top of the website page that works without problems even in the Japanese language. In this search feature there is an option to search within a category, but the registered categories are not appearing.
    And the search that is in the side menu just below the logo (shop by category) is disabled.
    I would like guidance on how to activate search features within a category.
    Thank you very much.



  • @William-Hatanaka
    Hi,
    If you are running shop in Japanese language then make sure category must also be translated in the japanese as well, otherwise the category menu is disabled.



  • @Vaishali-Agarwal, I've translated the name of each categories in Japanese.
    Just for the record, there is at least one product in each categories.
    I am looking for something that could be a the reason of this issue ... But I can not find the causer.
    Please help to find it.



  • @William-Hatanaka
    let me first confirm that categories tree are visible in EN_US locale in shop or it's the issue only in Japanese locale??
    Also mention the Bagisto Version.



  • @Vaishali-Agarwal , sorry I dd not remember now how I did it, but my page is only in Japanese language. I disabled the English version...



  • @Vaishali-Agarwal I checked the table velocity_contents and velocity_contents_translations.
    velocity_contents_translations.png velocity_contents.png
    And the query on the file
    packages>Webkul>Velocity>src>Repositories>ContentRepository.php
    Using the function dd() I transcribe the value of $formattedContent below:

    ^ array:5 [▼
      0 => array:4 [▶
        "title" => "テキスト"
        "page_link" => "textbook"
        "link_target" => 0
        "content_type" => "category"
      ]
      1 => array:4 [▶
        "title" => "神芝居・B4版"
        "page_link" => "kamishibaib4"
        "link_target" => 0
        "content_type" => "category"
      ]
      2 => array:4 [▶
        "title" => "神芝居・冊子版"
        "page_link" => "kamishibaibooklet"
        "link_target" => 0
        "content_type" => "category"
      ]
      3 => array:4 [▶
        "title" => "勾玉材料・オルゴナイト型"
        "page_link" => "orgonite"
        "link_target" => 0
        "content_type" => "category"
      ]
      4 => array:4 [▶
        "title" => "勾玉材料・オルゴナイト用水晶"
        "page_link" => "crystalfororganite"
        "link_target" => 0
        "content_type" => "category"
      ]
    ]
    

    And the value above is used on the following file:
    packages>Webkul>Velocity>src>Recources>views>shop>layouts>master.blade.php line #73
    and the value of json_encode($velocityContent)

    [{"title":"\u30c6\u30ad\u30b9\u30c8","page_link":"textbook","link_target":0,"content_type":"category"},{"title":"\u795e\u829d\u5c45\u30fbB\uff14\u7248","page_link":"kamishibaib4","link_target":0,"content_type":"category"},{"title":"\u795e\u829d\u5c45\u30fb\u518a\u5b50\u7248","page_link":"kamishibaibooklet","link_target":0,"content_type":"category"},{"title":"\u52fe\u7389\u6750\u6599\u30fb\u30aa\u30eb\u30b4\u30ca\u30a4\u30c8\u578b","page_link":"orgonite","link_target":0,"content_type":"category"},{"title":"\u52fe\u7389\u6750\u6599\u30fb\u30aa\u30eb\u30b4\u30ca\u30a4\u30c8\u7528\u6c34\u6676","page_link":"crystalfororganite","link_target":0,"content_type":"category"}]
    

    But I dont understand why the button is not enable to click?



  • Hey @Vaishali-Agarwal ,
    Did you read my question?
    Did you get some solution for it?
    Thank you !



  • Hi @William-Hatanaka
    Sorry for the delay.
    As we aren't getting this issue, so could you check while clicking on disabled icon is any console error attempt??



  • @Vaishali-Agarwal Hi, no error occurs....



  • @William-Hatanaka
    it seems that the main categories aren't selected under the root category.
    Please check all the main categories should select as here https://prnt.sc/sajtty



  • @Vaishali-Agarwal
    I deleted a category that existed since the installation of bagisto and it worked.
    Thank you so much !!!



  • @William-Hatanaka this solution worked for me too. I deleted the one directory I had created and all of the other directories automatically got deleted too including the root. However, when I tried deleting the root alone it refused to allow me to delete. thanks a lot, this issue troubled me for 2 days.



  • @Daisymond Great! 👍 👍


Log in to reply