Recent Topics

Edit Vue.js

  • Hi can I know whether I can edit the card-list.vue file? If it can, mind to share what the step is?

  • Hi @Shirah,

    Yeah! You can edit it according to your needs.

    Just go to packages/Velocity and run the command npm run watch, this will check your changes and will automatically place all your changes to the public path on saving. Once done just run command npm run prod to compile assets and then publish your packages by using php artisan vendor:publish --force.

  • watch
    cross-env NODE_ENV=development node_modules/webpack/bin/webpack.js --watch --progress --hide-modules --config=node_modules/laravel-mix/setup/webpack.config.js

    The system cannot find the path specified.
    throw er; // Unhandled 'error' event

    Error: spawn node_modules\webpack\bin\webpack.js ENOENT
    at notFoundError (C:\Users\rahul\AppData\Roaming\npm\node_modules\cross-env\node_modules\cross-spawn\lib\enoent.js:6:26)
    at verifyENOENT (C:\Users\rahul\AppData\Roaming\npm\node_modules\cross-env\node_modules\cross-spawn\lib\enoent.js:40:16)
    at ChildProcess.cp.emit (C:\Users\rahul\AppData\Roaming\npm\node_modules\cross-env\node_modules\cross-spawn\lib\enoent.js:27:25)
    at Process.ChildProcess._handle.onexit (node:internal/child_process:290:12)
    Emitted 'error' event on ChildProcess instance at:
    at ChildProcess.cp.emit (C:\Users\rahul\AppData\Roaming\npm\node_modules\cross-env\node_modules\cross-spawn\lib\enoent.js:30:37)
    at Process.ChildProcess._handle.onexit (node:internal/child_process:290:12) {
    code: 'ENOENT',
    errno: 'ENOENT',
    syscall: 'spawn node_modules\webpack\bin\webpack.js',
    path: 'node_modules\webpack\bin\webpack.js',
    spawnargs: [

    Getting above error when running the command. What is the issue can you explain and help?

  • @rahulanand84 said in Edit Vue.js:


    Hi @rahulanand84,

    What comand are you running and on which package you are running?

    1. I navigated to "Packages/Webkul/Velocity" and ran "npm install"
    2. Then I ran "npm run watch" and made all the changes in the UI vue component
      nothing is reflecting in the command prompt
    3. Finally I ran "npm run production" and it ran successfully.
    4. I rand vendor:publish command too

    after all this nothing worked. Changes were not reflecting on the website.

  • Till 3rd point, it's all right. But on the fourth point you need to use --force flag to see the changes.

    But make sure you have not customized something big otherwise your changes got reverted.

    I suggest you to places the file manually in the resources/themes path.

Log in to reply