Recent Topics

Problems with installer creating db



  • After 'Save & Continue' in the intstaller I get an empty card and the db tables are not created.

    I'm using the latest version, installed through git.

    Can anyone help me here?

    122749873_674743706770777_7510117801831273214_n.png



  • Hi Luc,
    you may try to install using the command line, where you can also check the errors if still any on database end.

    follow the below step to install using CLI:

    • add db_name, db_user, db_pass in .env file

    • execute the below command from the root directory one by one

    php artisan migrate
    
    php artisan db:seed
    
    php artisan vendor:publish --force
    

    press 0 to continue

    composer dump-autoload
    


  • Hi Vaishali,
    In CLI I get this error although I'm sure the db credentials in .env are correct:
    Screenshot 2020-12-11 at 11.08.15.png



  • @Luc
    please check the db_host also, it should be valid.
    You are getting this error it means somewhere DB parameters are given wrong.



  • @Vaishali-Agarwal
    These are my settings and they've always worked:
    DB_CONNECTION=mysql
    DB_HOST=127.0.0.1
    DB_PORT=3306



  • @Luc
    please check DB_NAME, DB_USER, DB_PASS.



  • @Vaishali-Agarwal
    Yes, they are all also correct:
    DB_CONNECTION=mysql
    DB_HOST=127.0.0.1
    DB_PORT=3306
    DB_DATABASE=aiosoft1_aio_demo
    DB_USERNAME=aiosoft1_aio_demo
    DB_PASSWORD=i4dBr*#4WMvY
    DB_PREFIX=

    Have already reset them and no difference



  • I just did a fresh setup to verify if there is a issue with the master branch, this is not the case.
    That means that this is a hosting environment issue, so what we suggest is to contact your hosting provider.

    You can of course also create a support ticket with your hosting credentials so that our support team can investigate this, in case your hosting provider can not provide a solution.
    Keep in mind that this is a paid service and costs € 48 per hour.


Log in to reply