Recent Topics

help set up



  • I am having issues on setting up bagisto. the error i keep encountering are

    Loading composer repositories with package information
    Updating dependencies
    Your requirements could not be resolved to an installable set of packages.

    Problem 1
    - maatwebsite/excel[3.1.28, ..., 3.1.30] require phpoffice/phpspreadsheet 1.16.* -> satisfiable by phpoffice/phpspreadsheet[1.16.0].
    - maatwebsite/excel[3.1.31, ..., 3.1.x-dev] require phpoffice/phpspreadsheet ^1.18 -> satisfiable by phpoffice/phpspreadsheet[1.18.0, 1.19.0].
    - maatwebsite/excel 3.1.27 requires phpoffice/phpspreadsheet ^1.16 -> satisfiable by phpoffice/phpspreadsheet[1.16.0, ..., 1.19.0].
    - maatwebsite/excel 3.1.26 requires phpoffice/phpspreadsheet ^1.15 -> satisfiable by phpoffice/phpspreadsheet[1.15.0, ..., 1.19.0].
    - phpoffice/phpspreadsheet[1.15.0, ..., 1.19.0] require ext-gd * -> it is missing from your system. Install or enable PHP's gd extension.
    - Root composer.json requires maatwebsite/excel ^3.1.26 -> satisfiable by maatwebsite/excel[3.1.26, ..., 3.1.x-dev].

    To enable extensions, verify that they are enabled in your .ini files:
    - C:\xampp\php\php.ini
    You can also run php --ini inside terminal to see which files are used by PHP in CLI mode.

    Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions.



    • Open xampp control panel.
    • Start apache and mysql.
    • Click on config option of apache.
    • Click on php.ini and open it.
    • Press Ctrl+F and search "extension=" or "extension=fileinfo".
    • On the next line to "extension=fileinfo", add "extension=gd".
    • Save the file.
    • Stop apache and restart it.

Log in to reply