Recent Topics

Problems after installation



  • Hello @all

    I've installed the v0.1.5 on both ways (gui/cli) and I end with the same errors.

    The site can be reached by /public, but per example /admin/login, /customer/register etc... are not found (error 404).

    The startpage on /public has following errors in chromdev console:

    fb610172-c385-48d8-8d7b-b7da7b0aee79-image.png

    I've tried the setup with Ubuntu 16.04 and 18.04.

    Thanks for your help
    Adrian



  • Hi,

    can u share screenshots of /admin/login & /customer/register pages.

    Thanks
    Rahul Shukla



  • The error you see above I resolved if I turn off APP_DEBUG in .env because PHPDebugbar is missing. I think the installation manual is missing some parts.

    Furthermore I don't know exactly how the structure of the public folder should be. I think here are resources missing. I get 404 errors accessing the /admin/login or /customer/register.

    Per example:

    Not Found
    The requested URL /bagisto/public/customer/login was not found on this server.
    

    Thanks for helping out.



  • Hi,

    Installation of project is right but your server configuration needs to change for it.

    For Apache Server -

    You need to provide override permission to all to your server (AllowOverride All) in apche configuration file which can be found in /etc/apache2/ directory named as apche2.conf, then run this command "sudo a2enmod rewrite" and restart your server.

    otherwise you can run the project using "php artisan serve" command to root of project.

    Thanks
    Rahul Shukla



  • and also install npm in Admin, Shop & Ui package & compile assests using "npm run watch" or "npm run watch-poll".



  • @rahul

    Great the Apache configuration setting already helped me to resolve the 404 errors.


Log in to reply