Recent Topics

Bagisto running very slow on AWS

  • Hi Rahul,
    I have already done all the steps you have mentioned. But still the image is not loading.
    I think while uploading the image gets corrupted, and can not load.
    The error message is "Could not load the image".
    What is the resolution for this?

  • Hi,

    Can you tell me size of your image & make sure that you have run 'php artisan vendor:publish' command & not renamed any folder.


  • our logo is 11KB only. We haven't rename any folder, and run the command 'php artisan vendor:publish'.
    What is the maximum size of upload image?

  • Hi,

    Can you share screenshot while uploading & error of front page, if you are running your project using 'php artisan serve' then app_url will be (APP_URL =


  • There is no error while uploading. The image gets uploaded . But when open the channel for edit, there is no image. Please refer image1.


    on front end also, the image look as it is on admin side.

  • Hi,

    Can you share screenshot using inspect of this image, i want to check its src, share your app_url from env & URL of your application.


  • Hi rahul,
    .env variable -

    application url:

    plz find inspect image below


  • Hi rahul,
    I have refer the link. after I run the command 'unlink public' from project root I got the message "unlink: cannot unlink ‘public’: Is a directory"

    please give me proper sequence to run the commands.

  • Hi @ppstech ,

    Please run following commands -

    From the project's root directory

    cd storage/app/public
    unlink public

    From the project's root directory run the following command:

    php artisan storage:link

    Follow the same sequence.


  • hi rahul,
    please find the image after running the commands


  • Hi @ppstech

    Please run following -

    From root of your project -

    cd public
    unlink storage

    From Root of Your Project

    php artisan storage:link


  • Hi @rahul ,
    Thanks for your reply. My logo is visible now. But products images are still not visible. Also I am not able to access other pages. Only the home page is visible. Not a single link is working. Please refer the image.


  • Hi @ppstech

    You have provide correct configuration to your web server, if you are using apche server then you can do following.

    Open Your apache2.conf file (Probably in etc->apche2 folder).

    Check in this file. you will find some think like -

    <Directory /var/www/html>
            Options Indexes FollowSymLinks
            AllowOverride None
            Require all granted

    Note - Directory path is not compulsory & content inside this can be differ, we only need to change AllowOverride None to All

    change it to

    <Directory /var/www/html>
            Options Indexes FollowSymLinks
            AllowOverride All
            Require all granted

    Please run following command after this -

    sudo a2enmod rewrite
    sudo /etc/init.d/apache2 restart
    sudo service apache2 restart

    If your using different web server than apache, please search for same.


  • Thanks for your reply. Its working now

  • From

    Gives this error page

  • Hi,

    Please clear cache using -

    php artisan config:clear
    php artisan cache:clear


Log in to reply